EC-CUBE 4 RCのインストールでMySQLの認証に失敗する

木曜日 , 11, 10月 2018 Leave a comment

 新しく環境を作るということでMySQLもバージョンアップしてみました。

 

$ mysqld –version
/usr/sbin/mysqld Ver 8.0.12 for Linux on x86_64 (MySQL Community Server – GPL) 

 

 バージョン8です。

 いまだに5とか使っていたので格段の進歩!

 

 ・・・だったんですが、EC-CUBE 4 RCのインストールでエラー。

 

SQLSTATE[HY000] [2054] The server requested authentication method unknown to the client

 

 コンソールからはログインできているのに・・・。

 ネットで調べてみるとmy.cnfに以下の一行を追加する必要があるとのこと。

 

default_authentication_plugin= mysql_native_password

 

 これで解決。

 というわけで、正式版が出たにも関わらずインストールしたRC版。


Please give us your valuable comment

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です